Manually upgrading to version 2.6.3

Overnight, the single-user WordPress of version 2.6.3 was released. This is considered a low-risk security upgrade, but already there’s a long thread and a trac ticket filed.

Only two files are affected – wp-includes/class-snoopy.php and version.php.

To upgrade wmpu 2.6.2 to 2.6.3 manually:

Make a backup of /wp-includes/class-snoopy.php

Download:

http://trac.wordpress.org/export/9310/tags/2.6.3/wp-includes/class-snoopy.php

Upload it to your server into /wp-includes/ folder.

Now you only have to change the version of your WPMU.
Edit /wp-includes/version.php and change “2.6.2” to “2.6.3”.

Thanks to user buzz_lightyear, who is my forum favorite of the day. I’d also like to point out that the file itself has changed very minorly, only 8 diffs. So.. you know… calm down. :)

Edit: Donncha has released WPMU 2.6.3, which includes this and some minor bug fixes, so you can do just the above if you’re only concerned about the security issue, or you can do a minor upgrade.

About andrea

City kid turned country wife, obsessive crafter.

Comments

  1. Just to clarify, this isn’t the only change between the two versions, right? This is just the security fix.

  2. blog money says:

    Thanks for the post. I will give this a try as soon as I can.
    I have been looking for information on this for quite some time. So I am very happy that you have posted it here for everyone. Thanks again.